Why aren't you using void Linux?

Why aren't you using void Linux?

Other urls found in this thread:


I am.

Because Gentoo is superior

I'm at a loss as to whether I should jump to Void or NixOS since Debian 8 has been a shitshow and I hate APT.

install gentoo

I always had lots of minor issues with NixOS that ended up making in unbearable

Does it have a GUI?

OpenBSD has better code quality, documentation, and security. What it loses in having a cucked license it makes up for in a uncucked code base.


The only correct answers to OP is either because openbsd. Or because install gentoo.

I can recommend Gentoo, install it

I'd use it but the device and partition naming is weird. How do you access filesystems on BSD? I'd like to just be bale to use head /dev/fd0 not something like head /dev/fch/df5

cuz i'm using artix

I use Gentoo.
Unfortunately, using Void is not for me (although I love the system), as base-system and linux are required packages and they both install proprietary drivers

I'd use it if:
- There was a way to automatize port building/configuration like Gentoo (or at least like Dfly's synth)
- Or even USE flags. Flavors are shit and Free/Dragonfly handle this better.

Dragonfly seems pretty good right now (but I'm comfy on Gentoo).

Other stuff:
- x264 doesn't even have a 10bit option
- the ffmpeg packages doesn't follow upstream versioning and doesn't even have zimg right now

Because I am using it.

The default installation does not come with anything other than the tty but there are versions with various DEs on the site.

As those are both meta packages you can just force uninstall the stuff they grab without fucking shit over.(As long as you have the proper alternatives installed)

What "alternatives" are there to linux-firmware-*

No reasonable BSD user looks at dfly and takes it seriously as a desktop

I am on my server. Runit is a comfy init. Not sure I'm ready to use something like Void as a desktop replacement yet though. I've been contemplating making the plunge to try out a compile-everything distro like Gentoo, but if it can be done the same in Void I'd rather just use Void. Anyone know?

Unless you need the GNOME hell or anything, why? It's one of the most up-to-date on the DRM drivers, too.

Void never struck me as a server distro, mind expatiating on why you use it for that purpose?

Because OP is a faggot.

Gentoo is just a meemee

install Devuan

Have it on my laptop, works great.

Because I already use the best OS.

You are a faggot

yes, binary packages from repo are compiled with xbps-src. you can do the same


I would prefer source based management as well, pkgsrc from netbsd seems really awesome, I wish it was in base. It already has support for OpenBSD too.
This is a general issue with BSDs, they don't share enough, they tend to fork and then never interact with one another again. I'd love to see OpenBSD devs work on Hammerfs as well for example.
ffmpeg doesn't follow release the version is just the date from when it's cloned from git and compiled.
zimg just doesn't have a port maintainer.

Because it's small and run by a bunch of amateurs. Same reason why I don't run teen jerkoff distros like Arch.

Not him, but pretty much all distros are the same when used as a server, once you get past the package management step. "Server distros" are for enterprise sysadmins who spend their free time shitposting on HN or Ars.

I am and this piece of shit fails to detect my touchpad on every second boot



Because I use Bedrock Linux with void as the init stratum.

Void is broken as hell, nothing unusual about a new distro. The problem is their disinterest in fixing what's broken at all, see the freetype bug that still, after 6 months, hasn't been fixed. So I tossed it and installed gentoo instead. Not looking back at all

xbps and runit are comfy, but void is broken, I might go back to it when it's ready for use and the documentation isn't a meme.


gentoo with systemd is best distro

Used Void for a while, but couldn't use it as my main machine, nor my second one. Now that I have a new laptop, I'm tempted to run Alpine Linux, since it feels more stable and less meme-y. Did anybody try Alpine around here?

That is the homoerotic version of devuan

Alpine is the definition of a meme. Tons of programs don't work on it because of the musl autism.

Yeah... nah you don't know what you're on about.

annoying as fuck, i can't run these containers on my 32 bit server

Because Arch GNU/Linux is better

freetype works fine, it's problem with your electron apps

what is broken?

it's not

Because I am a true /g/entooman.

Solaris Zones still has docker beat. Not ditching Linux for OpenSolaris kernel was a mistake.


Been using Void for over a year, nothing about it is broken.



Freetype is still broken on some my hardware, not just electron but any program that uses freetype, a perfect example is chromium glitching out until resized. On other systems I had several other dealbreaking problems, like iommu being forced on through the kernel settings causing uncountable arbitrary issues (fixed by recompiling it), vfio freezing the entire system when unbinding hardware, cmake completely ignoring the configuration, fucking up the raspberry pi kernel on one update, the kernel completely ignoring grub flags, xbps-src installation being generally unwieldy, etc.
It works fine if you're gonna use it as a facebook machine, for everything else it's just too much of a pain.

On the other hand runit is a dream, and xbps is a great package manager, albeit the naming being sometimes painful (screenFetch) and the mantainers being blithering idiots.

Why aren't you using default Ubuntu LTS?

then maybe you should report it? it can be musl issue as well (if you use it)
I can't help with those. Did you posted this issues on forum or asked on irc?
well, if it happens then there is an option in grub to boot older kernels
should work. how did you change them?
cd void-packages; xi package
package names are the same as in they source github.com/KittyKatt/screenFetch that's why they are case sensitive
but xbps-query is case insensitive, so it shouldn't be a problem

Why arent you using Windows 10 LTSB?

-No response, posted it atleast 2 months ago, know other people with the same issue
-Fixed it myself
-Stock grub, shouldn't be happening, couldn't be bothered to fix it yet, has happened to others aswell
-Some packages work (linux kernel), some do weird shit so I stopped bothering
-There's no upside to that


The AUR is bad and you should feel bad

Fuck off ovaltine spooge drinking nigger fucker.

But I already am!


I'm using it right now and it's pretty awful. Runit is extremely fast and LibreSSL is a nice plus, but it doesn't have anywhere near as large a repo as Gentoo or Arch+Aur. Package descriptions are pretty bad too and I don't know if I'm getting w3m or w3m+img-w3m. Besides those two pros, I also don't know why I would use Void over another distro. The selling point is "Its package system allows you to quickly install, update and remove software; software is provided in binary packages or can be built directly from sources with the help of the XBPS source packages collection" which mosts distros can do out of the box (and have a decent selection of packages).

And when something goes wrong, it's pretty hard to diagnose. Atleast with OpenBSD you get a mail archive and some logs. I don't know what the fuck is going on with my system when urxvt decides to shit the bed. Installing was kind of fucky too. Grub can't work with f2fs, but the installer allowed you to do it anyway without any warnings or indication it was not going to work. Messed around with it a little bit before I found the grub error and researched what the fuck it meant. Otherwise, it was pretty quick.

Wiki is kind of lean. Some things are missing info like how to setup automatic wpa_supplicant (it's easy to do, but still). Other times, it looks like a paragraph was spliced out and the writing doesn't make sense. I almost feel bad for calling this distro shit, because it doesn't seem like it's getting any love and people are genuinely wasting away their lives and all that they could become on this hunk of trash. I'll just switch back to Windows on this machine.

Hello friend.


fucking lol. You should learn to read tardo.

Why should I replace it over my Arch?

God fucking damn, I just looked through the entire repo and there it is, w3m-img, yet when I tried searching for w3m all I got was the regular one.

You need to use xbps-query -Rs "w3m" Both of them will come up and it will have a very short description.

I did, but I don't remember seeing w3m-mg.
It also took a few tries to get used to remembering xbps"

I use Gentoo.
Why aren't you using Gentoo, OP?

I want to move to void, but I don't know how to setup a full desktop environment from the base install. Surely there's a guide I would be recommended to look at?

Have you gotten a system up from a base install before?

Yes. That is the easiest part.
I'm not really sure how to progress from there though because I'm unsure of how best to chain things together so that I can get just werks performance like a meme de ootb deployment distro.

Idk man, it always been straight forward.

Install WM/DE --> Install Browser --> Install better editor --> Install file manager --> Install feh and mpv

And it just werks. What part of this are you unsure about? Fucking with configs?

sxiv is better.

But user. RD is cute. CUTE!

Every single distro is a broken piece of garbage holy shit. I tried void because it was pretty much the last distro I hadn't tried. It's just as broken and unstable as everything else except runit is even worse than systemd at keeping a system usable.

Apparently if you set void to install from local source it will imitate the configuration of the live image. Neat!

Anyway lxde from the repo is somehow fucked, if you install it from a minimal install when it runs it just shows 3 white blocks that have what looks like a terminal prompt in each one and a shitty clock sprite in the top right corner.

Fuck it, I'm moving to solaris. Fuck lincrap and wangblows and mac homOSeX and openplacebo and freecancer.



lol $10 says you break solaris in about a day

The liveusb doesn't even boot. Does that count?

It's not automatic. You're running x11, so you need to mess with the configs. The clock is part of an /etc/x11 config file.

It's not. Protip: USE=-dbus.

gentard logic.

You're the one moving to Solaris, retard. The point is don't use a faggot distro and faggot software if you wan't to complain.

My sides


Thanks for proving that gentards are clinically retarded.

This is what I was hoping there was a guide for.

Also void suicided when I rebooted it after doing the post-local-install update. I hope they can get it stable, I think void is a good idea.

That's absolutely undeniable.

You must've been doing something weird to nuke your distro. I think I only ever killed a distro once and that was fucking arch.

I wholeheartedly recommend the man pages. The only reason I ever started using them, was because I jumped into OpenBSD headfirst and HAD to customize my setup or else my workflow would be neutered. If you're running X11, do
man Xorg and scroll down to the "See Also." Look through all the files that start with X.

Usually setup is as simple as changing .xsession to have:
exec windowmanager &
The Arch wiki also has some guides that work for Linux in general if you tweak them a bit.

i prefer a functioning operating system.

What the fuck's void linux, and why should I care?

ITT Holla Forums struggles to use the equivalent of debian
lmfao are we neo-Holla Forums now?

I was running it in virtualbox to learn how to use it before doing a steel deployment.
the command I used was xbps-install -Su like the documentation recommends.

OY YOU FUCKER. I just re-read your first post about the 3 white blocks. You need to install a fucking desktop environment/ window manager and put it in your xseesion/xinit file. Do xbps-install [your fav manager like gnome or something] and RTFM.

are you new to linux? just go to tty and disable it
you can also add something like sv once /var/service/yourdm in its run script so it stops after first execution. learn how to use it instead of whining

examples: github.com/voidlinux/void-packages/blob/master/srcpkgs/lxappearance/template#L8

I'm using Devuan, but I'm about to completely jump off Linux because it's infected with poz.


Using Devuan too, but preparing to move to openbsd, at least on desktop, on pre-2009 laptops I run and will run Devuan, on post-2009 artix/slack, but will migrate after being familiar with *bsds.

Thanks. I got it working now.
Also I figured out how it suicided: I didn't allocate enough hdd space for it. I made the same mistake when I installed gentoo for the first time.

Because i use gentoo :^)

why i not have pc

use exherbo bitches

Tried. It chokes on compiling perl every time for some reason.

because :

1. I've never heard of it
2. Have no reason to use an OS tinkled with by presumably amateurs
3. I have Debian
4. If I had not Debian, I would probably go to Arch. If no Arch, I would reboot in Gentoo

lol enjoy your gnu/systemd retardo


Pajeet detected

the more I know

it was your humorous misusage of the word "tinkled" where you should have used "tinkered" combined with your poor grammar and the fact that the only image i had with "indian" in the name was indiansdrinkpiss.jpg"

Let's put it like this :

I'd rather use void Linux than a certain cucked license OS, but I'd rather not use it all - if that makes sense.


I don't like how it handles dependencies.
I can't find information if the musl version has the same packages available.
Last time I tried it installer crashed three times and wifi didn't work.
I fucking installed gentoo why don't they just get rid of the whole steaming shit and provide documentation like archfags do it.

Oh yeah lol, setting up wifi was a bitch. IIRC, do wpa_passphrase "SSID" "PASSWORD" > wpa.conf
wpa_supplicant -B -i[device] -cwpa.conf -Dwext -fwpa.log
dhcpcd [device]
Should work now or atleast give you enough to debug better. Couldn't for the life of me figure out dhcpcd hooks (wiki was shit) so I just put it in a startup file.

haha no thanks kiddo, im already using source mage

The conf file is /etc/wpa_supplicant/wpa_supplicant.conf

Why should I? The only reason anyone uses it to begin with is the persistent astroturf'd shilling across the chans.

Oh wow it's nothing

How is linux wireless so broken on the cli side?
In OpenBSD everything is ifconfig
Want the wifi to comeup on boot?
create a file /etc/hosname. and put in

are you retarded?

about wifi, it's really easy
wpa_supplicant -c

Because I have far too much shit to just up and migrate.
Also, I'm wondering whether to go with Calculate for Portage, FreeBSD for muh performance, OpenBSD for security or just do a plain Gentoo.
I don't much like OpenBSD's method of updating, but really that's not much of a reason to avoid it.
I did install Gentoo once before, but I've never had good luck with CLI networking, and I couldn't into it. All I want is an easy way to get into a network manager and DE and do everything from there.

I'm using Deepin on Manjaro right now, and god damn, this is the best experience normie UI experience I've had on Linux in a long time. Fuck everything else.

too many dependencies that should be optional on certain packages
that just crashes my luakit
also is wifish included in the default iso ?

OpenBSD is comfy.

The fuck are those?

they should be optional in xbps-scr as build-options, see
it's not the devs role to provide you unusable autism-level software without dbus and pulseaudio because you don't like it

try using decent browser. it even works in w3m

no and it won't be. build your own iso if you need it github.com/voidlinux/void-mklive

Your cuck distro whiteknighting is getting unbearable. How about you stop appealing to authority and your placebo linux related knowledge and think for a second what you're actually doing. I fucking say how my autism-level software behaves, what it has access to, when it fucking runs and when it fucking ends.

A piece of code should only have hard dependencies on things which are related to it's purpose.Everything else is niggers.

That's because of how w3m works, that will load in every possible command line browser.
and here's why it's beautiful

kindly fuck off
I'd rather go back to arch

No, it's a binary distro, so it's crazy to provide packages without dbus support or something like this, because it would fuck most of software and force normal users to waste their time adding basic stuff
Like i said, you can exclude whatever you don't like with xbps-src or just install cloveros

works in chromium, qutebrowser, firefox and w3m

The future

I am. :^)

Void is my personal daily driver.

Why should I be?

Plan 9

Because I use Manjaro.

i have void with enlightenment, nice desktop.
I am still used to debs and init scripts so I use antix on servers (needs custom kernel w/virtio enabled, and recompiled to dependence of postgresql from libsystemd) and void/mxlinux at home.

Because I already use a better distro.

Because I'm too much of a noob for this: troubleshooters.com/linux/void/quickinst.htm

When I get a second PC to fuck around with no consequences, maybe I'll try to figure out how that shit works, but right now I can't take that chance.


Because I'm not a horsefucker.

Fake news.

It is more meme than arch

That's odd, something seems to have gone wrong with your image upload. That's not the Slackware screenshot that should have gone there. But don't worry, we all understood what you really meant.

degentoo is garbage


Heck yeah, dweebs.

Because I use temple os

Why did Kevin succeed (Solus is Distrowatch top 5) and void shills haven't (void still hasn't even broken into Distrowatch top 100)?

because void is not for normies

because solus is a superior operating system

I've run Arch, Ubuntu, OpenSUSE, Puppy, FreeBSD, Void, and lots of other operating systems/distros. Have been on Solus for about a year now. Solid rolling-release distro. I haven't tried Gentoo though, but I'd like to see how a source-based distro compares to a binary distro.

systemDicks as usual.

Because I'm an Archfag. Give me a reason to switch.

mom cancel my meetings pacman broke my xorg.conf again

Obligatory tutorial post regarding how to install gentoo for noobs.
Its very simple.


This next video is actually really helpful for people after they have the core system on how to get it up and running with all the needed tools

arch has been going downhill, lately.
Also RunIT is faster (and better overall) than systemD. i also prefer xbps over pacman. void supports musl, if you want to use it (musl is better for servers and old/low-end hardware). void is less bloated than arch.

Looks nice!

This video helped me to understand:: youtube.com/watch?v=0m6hoOelZH8&list=PLE18841CABEA24090&index=13&t=34m37s

Because it won't install my system properly with encrypted /boot. Kernel hangs after decryption

Why not the Wii? It's basically an over-clocked Gamecube with more RAM and actually has USB ports for accessories.

I need Windows for PdaNet+ tethering on my Android phone. I have unlimited T-Mobile data for my job, I'm not paying Cox another $80/month to connect my desktop to the internet. I'm only on my desktop a few hours per week.
PdaNet+ is the only tethering app I know of that hides tether usage from T-Mobile.

Because I'm using instantiated Linux.


no thx

u mad bra?

Huge repos without the need to use the AUR with its retarded kiddies. Can escape easily the gtk3/dbus cancer.


It's shit.

I'm about to install it on my new ThinkPad I'm getting

I'm about to install it on my new ThinkPad I'm getting

the fuck just happened

I am writing an ansible script for void setup. Once that is done I will deploy it on my laptop.

You do use some kind of management flow for your hardware? Don’t you onichan?

If you are using ansible for a single computer / server you are being retarded.

Absolutely pleb

I would be doing what you're doing but I caught the reproducibility bug and am now stuck on NixOS, I will move to GuixSD if it ever gets out of beta.


I want NixOS mixed with IPFS mixed with docker mixed with a reproducible compiler. This would allow for totally reproducible systems deployable to any environment. At the moment none of those tools by themselves actually accomplish that very well. NixOS has repos that will go down eventually, IPFS has no package mechanism, docker is too dependent on a dynamic build environment (the internet) that will change.

NixOS doesn't need docker, NixOS and GuixSD deprecate docker.

Someone is already working on it

Yea it does, docker does way more shit than NixOS does.

What did he mean by this

would anyone be interested in a base-packages-libre/linux-libre package? I'm sick of seeing linux-firmware-* installed even if I've deleted the files

Yeah, you illiterate teenager.

Nay, ye of little intellect.

The word "yea" in an archaic context is used to conjoin two separate sentences, oftentimes paired with a semicolon and is in no way similar to the word "yeah" in definition. The modern use of the word "yea" is a formal way of showing consent; e.g. "yea or nay?" In either form, the word "yea" is isn't even phonetically comparable to the word "yeah", as "yea" is pronounced like the word "yay", which is why people will oftentimes conflate "yea" with "yay" when confirming assent, o þe of little intellect.


All conventional pack managers are dependent on a collection of package servers. Trry updating an old version of Ubuntu, or NixOS, or Fedora. It won't work because the servers are down or the packages deleted. Obviously you could run a mirror for everything but who the fuck wants to do that.


You want to have reproducible builds of discontinued and unsupported versions of an entire OS without mirroring the repos, either the binaries or the source files, or building an image. Not even IPFS would keep mainstream availability of shit like Gimp 0.99, let alone whole fucking repos of useless, unpatched and obscure bitrotting retro software. If you really want to stay out of the loop for so long, you should ensure it yourself.

People who really want reproducibility because they need it rather than because they like memeing on imageboards about it generally do that. NixOS was built with that in mind.

If even one person has it you are wrong.

This is needed in so many cases, unironically yes.

The fork github repos for libraries they use, no one ever does that for their OS repositories. And it would be 10x less labor if they did not HAVE to do that.

I don't think docker does more, what does it do that NixOS doesn't?

No systemd support.


I have five computers. So I manage them with ansible.

what a waste

You don't know me! Never speak to me or my computers ever again.

Is it KDE Neon?
Then as an artist who requires stability with up to date KDE software (krita, kdenlive) I see very little reason in switching

I know you perfectly well. You're the kind of person who sees a colorscheme and then jams that colorscheme into every single piece of software whether it can handle it or not.

Nice non-animated gif, faggot.

I know you perfectly well. You're the kind of person who spends his weekends aimlessly ricing, configuring or compulsively distro-hopping in a vain attempt to escape the soul-crushing realization that your life is devoid of meaning or value.

I'm not even who you were talking to, but you're a colossal transparent faggot.

lol no but thanks for joining in internet stranger.

pick one.
Honestly, you should probably use OpenSUSE, if you want the best and most stable KDE experience.

Omg that video

the only reason to use suse [and fedora] is you work somewhere with the same software

Thank you, my physique has been looking pretty muscular recently.


Quit your bitching, I converted it into a PNG since the gif seemed to not work

You're retarded. KDE Neon is the most stable KDE experience you can get since, y'know, actual fucking KDE devs maintain it

Why does it look the same but have a bigger file size?

At least upload the working gif, moron. God, you furfags can't do anything right.

Was posting from my phone. Apparently iJew doesn't allow you to download working gifs unless you use their browser. It works now

Wow. A retard, furry, and proprietary cuck.

Why did you have to upload it again when it was already posted? Jesus christ, man.

So, antiX, Void, Manjaro, or Zenwalk?

none of the above

iOS > Android any time
Both give zero fucks about your privacy anyways so I pick the one that's more secure, stable and longer supported

All of those are garbage. Install Ubuntu

This is why the only sane option is to package everything yourself.
Idiots thinking the distro actually matters, lmao.

because i'm using arch linux

might try gentoo one day but Arch Linux is just workable for whatever. You can compile your own stuff if you want and their binaries are up to do date.

There's usually a way to build the stuff you need on it too, even if you do have to make a container etc

Installed it yesterday and noticing some stupity with it.
xbps-query, by default only brings up a list of currently installed packages, not those listed in the repo; so if I want to do say - $sudo xbps-query emacs it returns nothing unless you give it the -R switch to explicitly search the registered repo. Kinda silly behavior.
And I hate when a package maintainer just symlinks firefox to GNU icecat, which seems to be the case here as on Debian or Ubuntu. For instance, on the version of Icecat I have from the repo it allows playback of DRM content, something which I find appaling to be included at all; along with google search being the default, but the GNU icecat page says it uses DDG for the default.
Overall, not very impressed. Gonna try NixOS with GUIX next.

I'm really interested in what kind of browsers NixOS has.

Why the fuck was uploading the same furshit image 4 times necessary? at least post good furshit